Singapore performance degradation

Incident Report for TCPShield

Resolved

The degradation has been resolved and continuing to monitor.
Posted Nov 23, 2025 - 06:40 UTC

Monitoring

We have applied a corrective fix for the NIC driver issue observed and are monitoring results.
Posted Nov 23, 2025 - 06:28 UTC

Investigating

Since 06:00 UTC we have observed performance degradation in Singapore, we are investigating. Root cause is not an attack.
Posted Nov 23, 2025 - 06:21 UTC
This incident affected: Asia Network (Singapore).