Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 20, 2025 - 01:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Sep 20, 2025 - 01:00 UTC
Scheduled
At 01:00 UTC, we will deploy a global mitigation code update across all regions on a rolling basis, starting with Asia. While no service impact is anticipated, we are providing advance notice as a precautionary measure.
Posted Sep 19, 2025 - 01:52 UTC
This scheduled maintenance affected: North America Network (Ashburn, Los Angeles, Seattle, Miami, Dallas), Europe Network (London, Frankfurt (Anycast), Amsterdam, Warsaw), and Asia Network (Singapore, Tokyo, Sydney).