Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 01, 2025 - 10:00 UTC
Scheduled
We will be undergoing scheduled maintenance at this time to further upgrade capacity in Vint Hill. This is adding additional capacity to our already completed upgrades from yesterday
These changes are necessary to support the ongoing botnet and attack environment. Before then, traffic will be drained from the location such that minimal traffic is disrupted during the window.
Posted Sep 30, 2025 - 07:01 UTC
This scheduled maintenance affected: North America Network (Ashburn).