Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 24, 2025 - 02:00 UTC
Scheduled
At 02:00 UTC (early Friday morning), we will be performing kernel upgrades to our Warsaw location for increased performance and long term stability. Before this window traffic will be drained to our Frankfurt location until maintenance is concluded to ensure seamless experience.
Posted Oct 20, 2025 - 21:02 UTC
This scheduled maintenance affected: Europe Network (Warsaw).