North America backbone degradation

Incident Report for TCPShield

Resolved

The issue has not re-surfaced since corrective changes to these regions.
Posted Jul 18, 2025 - 23:33 UTC

Monitoring

The impacted sites have had their traffic diverted via alternate T1 upstreams at this time
Posted Jul 18, 2025 - 23:27 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 18, 2025 - 23:18 UTC

Investigating

Since 21:00 UTC, we have observed several backbone degradation events in North America via GSL (our upstream), with Los Angeles and Ashburn being the primary impact sites
Posted Jul 18, 2025 - 23:18 UTC
This incident affected: North America Network (Ashburn, Los Angeles).