High latency via Mexico / Dallas

Incident Report for TCPShield

Resolved

This incident has been resolved.
Posted Sep 20, 2025 - 08:43 UTC

Monitoring

We observed elevated latency via southern connections since 15:23 UTC. We have re-routed traffic at 16:08 UTC via alternate paths. We can see latency has dropped again significantly for these routes. This optimization primarily is for Sentry / VXLAN tunnel customers.

If any weird routes you see, please forward us a traceroute. Thanks!

We will keep this status as monitoring for the time being.
Posted Sep 20, 2025 - 05:11 UTC
This incident affected: North America Network (Miami, Dallas).